AWS services down

Incident Report for Loop and Tie

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 19:13 CDT

Update

App is back up
Posted Oct 20, 2025 - 19:12 CDT

Update

AWS service has been restored, but our production environment is still experiencing long load times and crashes. QA and Demo should be back to normal functionality
Posted Oct 20, 2025 - 18:28 CDT

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 15:13 CDT

Investigating

AWS is currently experiencing an outage which is affecting our applications
Posted Oct 20, 2025 - 11:12 CDT
This incident affected: Dashboard and Supplier Dashboard.